import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\[\\{,:\\]\\}]+[\\[\\{,:\\]\\}\\s]*\"(*SKIP)(*FAIL)|\"(?!\\s*[\\[\\{,:\\]\\}]))";
final String string = "{\"Equipment Contents\":[\"XL APPEARANCE GROUP\",\"body-color grille\",\"body-color body-side molding with chrome insert\",\"luggage rack\",\"15\" deep-dish cast aluminum wheels\",\"P235/75R15SL all-terrain OWL tires\",\"power door locks\",\"power windows\",\"p\n"
+ "ower mirrors\",\"cloth captains chairs\"]}";
final String subst = "\\\\$0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}