using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[a-z0-9]+)\/(?:(?:v(?:10|\d)\.[0-9]{1,2}\.[0-9]{1,2})|week[0-9]{1,2})$";
string input = @"bqcloud/v1.0.0
becloud/v1.0.0
dfx37/v1.0.1
dfx37cloud/v9.11.6
dfx37/week12
dfx37/v1.0.0
bxc53fb/v1.0.0
feature/BXC53FB/test
feature/BECLOUD-1/test
feature/BQCLOUD-1/lf
feature/BE21CLOUD-1/test
feature/DFX37-37/dftest
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}