// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[a-z0-9]+)\/(?:(?:v(?:10|\d)\.[0-9]{1,2}\.[0-9]{1,2})|week[0-9]{1,2})$").unwrap();
let string = "bqcloud/v1.0.0
becloud/v1.0.0
dfx37/v1.0.1
dfx37cloud/v9.11.6
dfx37/week12
dfx37/v1.0.0
bxc53fb/v1.0.0
feature/BXC53FB/test
feature/BECLOUD-1/test
feature/BQCLOUD-1/lf
feature/BE21CLOUD-1/test
feature/DFX37-37/dftest
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}