import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-z0-9]+)\\/(?:(?:v(?:10|\\d)\\.[0-9]{1,2}\\.[0-9]{1,2})|week[0-9]{1,2})$";
final String string = "bqcloud/v1.0.0\n"
+ "becloud/v1.0.0\n"
+ "dfx37/v1.0.1\n"
+ "dfx37cloud/v9.11.6\n"
+ "dfx37/week12\n\n"
+ "dfx37/v1.0.0\n"
+ "bxc53fb/v1.0.0\n\n"
+ "feature/BXC53FB/test\n"
+ "feature/BECLOUD-1/test\n"
+ "feature/BQCLOUD-1/lf\n\n"
+ "feature/BE21CLOUD-1/test\n"
+ "feature/DFX37-37/dftest\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}