import re
regex = re.compile(r"^(?:[a-z0-9]+)\/(?:(?:v(?:10|\d)\.[0-9]{1,2}\.[0-9]{1,2})|week[0-9]{1,2})$", flags=re.MULTILINE)
test_str = ("bqcloud/v1.0.0\n"
"becloud/v1.0.0\n"
"dfx37/v1.0.1\n"
"dfx37cloud/v9.11.6\n"
"dfx37/week12\n\n"
"dfx37/v1.0.0\n"
"bxc53fb/v1.0.0\n\n"
"feature/BXC53FB/test\n"
"feature/BECLOUD-1/test\n"
"feature/BQCLOUD-1/lf\n\n"
"feature/BE21CLOUD-1/test\n"
"feature/DFX37-37/dftest\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")