package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\.$`)
var str = []byte(`10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 000.0110, 120, 130, 260, 330`)
var substitution = []byte("$1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}