const regex = /^\.$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\.$', '')
const str = `10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 000.0110, 120, 130, 260, 330`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);