use strict;
my $str = '<title name="Article">Article</title><title name="article_1">text Article text article dfdsf</title>';
my $regex = qr/(\G|>)[^<>]*?\Karticle/ip;
my $subst = 'MyText';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";