$re = '/(\G|>)[^<>]*?\Karticle/i';
$str = '<title name="Article">Article</title><title name="article_1">text Article text article dfdsf</title>';
$subst = "MyText";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;