re = /(\G|>)[^<>]*?\Karticle/i
str = '<title name="Article">Article</title><title name="article_1">text Article text article dfdsf</title>'
subst = 'MyText'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result