const regex = new RegExp('\\\\"', 'gm')
const str = ` {
\\"abc\\": \\"test\\",
\\"xyz\\": \\"test1\\",
\\"array\\": [
{
\\"path\\": [\\"test\\"],
\\"output\\": {}
}
]
} `;
const subst = `"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);