$re = '~\\\\"~m';
$str = ' {
\\"abc\\": \\"test\\",
\\"xyz\\": \\"test1\\",
\\"array\\": [
{
\\"path\\": [\\"test\\"],
\\"output\\": {}
}
]
} ';
$subst = "\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;