use strict;
my $str = ' {
\\"abc\\": \\"test\\",
\\"xyz\\": \\"test1\\",
\\"array\\": [
{
\\"path\\": [\\"test\\"],
\\"output\\": {}
}
]
} ';
my $regex = qr~\\"~mp;
my $subst = '"';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";