#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([-a-zA-Z0-9]+)(\.[0-9a-z]{2,5})$"
Local $sString = "http://www.blogcdn.com/slideshows/images/slides/218/885/9/S2188859/slug/l/765-1.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")