$re = '/([-a-zA-Z0-9]+)(\.[0-9a-z]{2,5})$/';
$str = 'http://www.blogcdn.com/slideshows/images/slides/218/885/9/S2188859/slug/l/765-1.jpg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);