re = /([-a-zA-Z0-9]+)(\.[0-9a-z]{2,5})$/
str = 'http://www.blogcdn.com/slideshows/images/slides/218/885/9/S2188859/slug/l/765-1.jpg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end