const regex = /([-a-zA-Z0-9]+)(\.[0-9a-z]{2,5})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([-a-zA-Z0-9]+)(\\.[0-9a-z]{2,5})$', '')
const str = `http://www.blogcdn.com/slideshows/images/slides/218/885/9/S2188859/slug/l/765-1.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}