#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)<img[^>]*alt=['"].+['"]"
Local $sString = ".. <img src="alt.png" class="absmiddle" alt="" /> .." & @CRLF & _
"" & @CRLF & _
".. <img src="alt.png" class="absmiddle" /> alt="ok" .." & @CRLF & _
"" & @CRLF & _
".. <img src="alt.png" class="absmiddle" alt="its_ok" /> .." & @CRLF & _
"" & @CRLF & _
".. <img src="alt.png" class="absmiddle" alt> .."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")