re = /<img[^>]*alt=['"].+['"]/mi
str = '.. <img src="alt.png" class="absmiddle" alt="" /> ..
.. <img src="alt.png" class="absmiddle" /> alt="ok" ..
.. <img src="alt.png" class="absmiddle" alt="its_ok" /> ..
.. <img src="alt.png" class="absmiddle" alt> ..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end