using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[^>]*alt=['""].+['""]";
string input = @".. <img src=""alt.png"" class=""absmiddle"" alt="" /> ..
.. <img src=""alt.png"" class=""absmiddle"" /> alt=""ok"" ..
.. <img src=""alt.png"" class=""absmiddle"" alt=""its_ok"" /> ..
.. <img src=""alt.png"" class=""absmiddle"" alt> ..";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}