$re = '/<img[^>]*alt=[\'"].+[\'"]/mi';
$str = '.. <img src="alt.png" class="absmiddle" alt="" /> ..
.. <img src="alt.png" class="absmiddle" /> alt="ok" ..
.. <img src="alt.png" class="absmiddle" alt="its_ok" /> ..
.. <img src="alt.png" class="absmiddle" alt> ..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);