# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!")(\b\d+\b)(?!")/"$1"/g;t' <<< "0000,0767,\"078\", 0785, \"0723\",23487, 345 , 07334"