const regex = /(?<!")(\b\d+\b)(?!")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!")(\\b\\d+\\b)(?!")', 'g')
const str = `0000,0767,"078", 0785, "0723",23487, 345 , 07334`;
const subst = `"$1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);