import re
regex = re.compile(r"(?<!\")(\b\d+\b)(?!\")")
test_str = "0000,0767,\"078\", 0785, \"0723\",23487, 345 , 07334"
subst = "\"$1\""
result = regex.sub(subst, test_str)
if result:
print(result)