using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!"")(\b\d+\b)(?!"")";
string substitution = @"""$1""";
string input = @"0000,0767,""078"", 0785, ""0723"",23487, 345 , 07334";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}