$re = '/(?<!")(\b\d+\b)(?!")/';
$str = '0000,0767,"078", 0785, "0723",23487, 345 , 07334';
$subst = "\"$1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;