# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d{3})\d{7}$/\1/gm;t' <<< "12abc
111
1234567891
12
"