package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{3})\d{7}$`)
var str = `12abc
111
1234567891
12
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}