$re = '/^(\d{3})\d{7}$/m';
$str = '12abc
111
1234567891
12
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;