import re
regex = re.compile(r"^(\d{3})\d{7}$", flags=re.MULTILINE)
test_str = ("12abc\n"
"111\n"
"1234567891\n"
"12\n\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)