use strict;
my $str = '12abc
111
1234567891
12
';
my $regex = qr/^(\d{3})\d{7}$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";