const regex = /(?s)\n[^\n]*start[^\n]*\n((?:.(?!start))*?)\n[^\n]*end/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\n[^\\n]*start[^\\n]*\\n((?:.(?!start))*?)\\n[^\\n]*end', '')
const str = `11111111111
123start123
1111111111
4567start4567
****
****
****
789end789
1234end1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}