import Foundation
let pattern = #"(?s)\n[^\n]*start[^\n]*\n((?:.(?!start))*?)\n[^\n]*end"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
11111111111
123start123
1111111111
4567start4567
****
****
****
789end789
1234end1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}