re = /(?s)\n[^\n]*start[^\n]*\n((?:.(?!start))*?)\n[^\n]*end/
str = '11111111111
123start123
1111111111
4567start4567
****
****
****
789end789
1234end1234'
# Print the match result
str.match(re) do |match|
puts match.to_s
end