#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:UniquePrefixA|UniqueB|UniqueC)\s*(\[some-token\])(?:and|\s)*(\[some-token\])?(\s|[^\[\]])*(\[some-token\])?(\s|[^\[\]])*(\[some-token\])?(\s|[^\[\]])*"
Local $sString = "Examples 1-3:" & @CRLF & _
"[1] UniquePrefixA [some-token] and [some-token] want to take [some-token] to see some monkeys." & @CRLF & _
"[2] UniqueC [some-token] wants to take [some-token] to the store. UniqueB, [some-token] is in the pattern once more." & @CRLF & _
"[3] UniquePrefixA [some-token] is using [some-token] to [some-token]. " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")