import re
regex = re.compile(r"(?:UniquePrefixA|UniqueB|UniqueC)\s*(\[some-token\])(?:and|\s)*(\[some-token\])?(\s|[^\[\]])*(\[some-token\])?(\s|[^\[\]])*(\[some-token\])?(\s|[^\[\]])*", flags=re.IGNORECASE)
test_str = ("Examples 1-3:\n"
"[1] UniquePrefixA [some-token] and [some-token] want to take [some-token] to see some monkeys.\n"
"[2] UniqueC [some-token] wants to take [some-token] to the store. UniqueB, [some-token] is in the pattern once more.\n"
"[3] UniquePrefixA [some-token] is using [some-token] to [some-token]. \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")