using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:UniquePrefixA|UniqueB|UniqueC)\s*(\[some-token\])(?:and|\s)*(\[some-token\])?(\s|[^\[\]])*(\[some-token\])?(\s|[^\[\]])*(\[some-token\])?(\s|[^\[\]])*";
string input = @"Examples 1-3:
[1] UniquePrefixA [some-token] and [some-token] want to take [some-token] to see some monkeys.
[2] UniqueC [some-token] wants to take [some-token] to the store. UniqueB, [some-token] is in the pattern once more.
[3] UniquePrefixA [some-token] is using [some-token] to [some-token].
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}