import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:UniquePrefixA|UniqueB|UniqueC)\\s*(\\[some-token\\])(?:and|\\s)*(\\[some-token\\])?(\\s|[^\\[\\]])*(\\[some-token\\])?(\\s|[^\\[\\]])*(\\[some-token\\])?(\\s|[^\\[\\]])*";
final String string = "Examples 1-3:\n"
+ "[1] UniquePrefixA [some-token] and [some-token] want to take [some-token] to see some monkeys.\n"
+ "[2] UniqueC [some-token] wants to take [some-token] to the store. UniqueB, [some-token] is in the pattern once more.\n"
+ "[3] UniquePrefixA [some-token] is using [some-token] to [some-token]. \n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}