// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:UniquePrefixA|UniqueB|UniqueC)\s*(\[some-token\])(?:and|\s)*(\[some-token\])?(\s|[^\[\]])*(\[some-token\])?(\s|[^\[\]])*(\[some-token\])?(\s|[^\[\]])*").unwrap();
let string = "Examples 1-3:
[1] UniquePrefixA [some-token] and [some-token] want to take [some-token] to see some monkeys.
[2] UniqueC [some-token] wants to take [some-token] to the store. UniqueB, [some-token] is in the pattern once more.
[3] UniquePrefixA [some-token] is using [some-token] to [some-token].
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}