using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"if {1,}then";
string input = @"if offline(@|PLC|@) and secondsnoconnection >= 10 then
begin
state := 1;
status_reason := 12;
status_reason_detail := 0;
end
else if @|PLC|@:Rotation_fault = true then
begin
state := 1;
status_reason := 100712;
status_reason_detail := 0;
seconds := 0;
secondsnoconnection := 0;
end
else if @|PLC|@:Course_rework = true and @|PLC|@:Machine_exploitation_mode = 2 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 then
begin
state := 1;
status_reason := 100713;
status_reason_detail := 0;
seconds := 0;
secondsnoconnection := 0;
end
else if @|PLC|@:Machine_exploitation_mode = 1 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 then
begin
state := 1;
status_reason := 100715;
status_reason_detail := 0;
seconds := 0;
secondsnoconnection := 0;
end
else if @|PLC|@:Machine_exploitation_mode = 2 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 and @|PLC|@:Speed_order < 95 then
begin";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}