# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"if {1,}then"
test_str = ("if offline(@|PLC|@) and secondsnoconnection >= 10 then\n"
"begin\n"
"state := 1;\n"
"status_reason := 12;\n"
"status_reason_detail := 0;\n"
"end\n"
"else if @|PLC|@:Rotation_fault = true then\n"
"begin\n"
"state := 1;\n"
"status_reason := 100712;\n"
"status_reason_detail := 0;\n"
"seconds := 0;\n"
"secondsnoconnection := 0;\n"
"end\n"
"else if @|PLC|@:Course_rework = true and @|PLC|@:Machine_exploitation_mode = 2 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 then\n"
"begin\n"
"state := 1;\n"
"status_reason := 100713;\n"
"status_reason_detail := 0;\n"
"seconds := 0;\n"
"secondsnoconnection := 0;\n"
"end\n"
"else if @|PLC|@:Machine_exploitation_mode = 1 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 then\n"
"begin\n"
"state := 1;\n"
"status_reason := 100715;\n"
"status_reason_detail := 0;\n"
"seconds := 0;\n"
"secondsnoconnection := 0;\n"
"end\n"
"else if @|PLC|@:Machine_exploitation_mode = 2 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 and @|PLC|@:Speed_order < 95 then\n"
"begin")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.