package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)if {1,}then`)
var str = `if offline(@|PLC|@) and secondsnoconnection >= 10 then
begin
state := 1;
status_reason := 12;
status_reason_detail := 0;
end
else if @|PLC|@:Rotation_fault = true then
begin
state := 1;
status_reason := 100712;
status_reason_detail := 0;
seconds := 0;
secondsnoconnection := 0;
end
else if @|PLC|@:Course_rework = true and @|PLC|@:Machine_exploitation_mode = 2 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 then
begin
state := 1;
status_reason := 100713;
status_reason_detail := 0;
seconds := 0;
secondsnoconnection := 0;
end
else if @|PLC|@:Machine_exploitation_mode = 1 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 then
begin
state := 1;
status_reason := 100715;
status_reason_detail := 0;
seconds := 0;
secondsnoconnection := 0;
end
else if @|PLC|@:Machine_exploitation_mode = 2 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 and @|PLC|@:Speed_order < 95 then
begin`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}