import Foundation
let pattern = #"if {1,}then"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
if offline(@|PLC|@) and secondsnoconnection >= 10 then
begin
state := 1;
status_reason := 12;
status_reason_detail := 0;
end
else if @|PLC|@:Rotation_fault = true then
begin
state := 1;
status_reason := 100712;
status_reason_detail := 0;
seconds := 0;
secondsnoconnection := 0;
end
else if @|PLC|@:Course_rework = true and @|PLC|@:Machine_exploitation_mode = 2 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 then
begin
state := 1;
status_reason := 100713;
status_reason_detail := 0;
seconds := 0;
secondsnoconnection := 0;
end
else if @|PLC|@:Machine_exploitation_mode = 1 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 then
begin
state := 1;
status_reason := 100715;
status_reason_detail := 0;
seconds := 0;
secondsnoconnection := 0;
end
else if @|PLC|@:Machine_exploitation_mode = 2 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 and @|PLC|@:Speed_order < 95 then
begin
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)