import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "if {1,}then";
final String string = "if offline(@|PLC|@) and secondsnoconnection >= 10 then\n"
+ "begin\n"
+ "state := 1;\n"
+ "status_reason := 12;\n"
+ "status_reason_detail := 0;\n"
+ "end\n"
+ "else if @|PLC|@:Rotation_fault = true then\n"
+ "begin\n"
+ "state := 1;\n"
+ "status_reason := 100712;\n"
+ "status_reason_detail := 0;\n"
+ "seconds := 0;\n"
+ "secondsnoconnection := 0;\n"
+ "end\n"
+ "else if @|PLC|@:Course_rework = true and @|PLC|@:Machine_exploitation_mode = 2 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 then\n"
+ "begin\n"
+ "state := 1;\n"
+ "status_reason := 100713;\n"
+ "status_reason_detail := 0;\n"
+ "seconds := 0;\n"
+ "secondsnoconnection := 0;\n"
+ "end\n"
+ "else if @|PLC|@:Machine_exploitation_mode = 1 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 then\n"
+ "begin\n"
+ "state := 1;\n"
+ "status_reason := 100715;\n"
+ "status_reason_detail := 0;\n"
+ "seconds := 0;\n"
+ "secondsnoconnection := 0;\n"
+ "end\n"
+ "else if @|PLC|@:Machine_exploitation_mode = 2 and @|PLC|@:Machine_state = 3 and @|PLC|@:Machine_state_mode = 2 and @|PLC|@:NC_Mode = 1 and @|PLC|@:Speed_order < 95 then\n"
+ "begin";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}