import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<s>[-+])?(?P<o><)?(?(s)|[-+]?)\\d+(?:\\.\\d+(?:[Ee][-+]\\d+(?:\\.\\d+)?)?)?(?(o)>|)$";
final String string = "-11.88\n"
+ "<0.012541>\n"
+ "-<3.14>\n"
+ "<-2.98>\n"
+ "-<3.2e-32>\n\n"
+ "-<-2>\n"
+ "<eeeee>\n"
+ "-<3.2e-3.2.2>\n"
+ "-<3.e--3.22>\n"
+ "-<3.ee-3.22>\n"
+ "<1.23\n"
+ "<-abcdefg>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}