$re = '/^(?P<s>[-+])?(?P<o><)?(?(s)|[-+]?)\d+(?:\.\d+(?:[Ee][-+]\d+(?:\.\d+)?)?)?(?(o)>|)$/m';
$str = '-11.88
<0.012541>
-<3.14>
<-2.98>
-<3.2e-32>
-<-2>
<eeeee>
-<3.2e-3.2.2>
-<3.e--3.22>
-<3.ee-3.22>
<1.23
<-abcdefg>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);