using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^,],[^,]";
string input = @"8/15/2016,,Amazon,,15.93
8/24/2016,,Google,18.73
8/26/2016,,Ebay,,60.2
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}