package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^,],[^,]`)
var str = `8/15/2016,,Amazon,,15.93
8/24/2016,,Google,18.73
8/26/2016,,Ebay,,60.2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}