// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^,],[^,]").unwrap();
let string = "8/15/2016,,Amazon,,15.93
8/24/2016,,Google,18.73
8/26/2016,,Ebay,,60.2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}