re = /[^,],[^,]/
str = '8/15/2016,,Amazon,,15.93
8/24/2016,,Google,18.73
8/26/2016,,Ebay,,60.2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end